Instalar LibreOffice 3.5 en Ubuntu

A mediados de febrero The Document Foundation liberó la versión 3.5 del la suite LibreOffice. Está previsto que sea la suite ofimática por defecto en Ubuntu 12.04 Precise Pangolin. No obstante puede instalarse en sistemas con versiones anteriores de Ubuntu. Como habrá usuarios que no van a cambiar/actualizar su versión de Ubuntu, vamos a ver como podemos instalarla:

 

CONSIDERACIONES PREVIAS

1ª – LibreOffice y OpenOffice no pueden coexistir en el mismo sistema, por lo tanto aquellos que deseen instalar la nueva suite deberán primero desinstalar (si es el caso) OpenOffice. Para ello, nos vamos a una terminal y tecleamos,

sudo apt-get remove openoffice*

 

2ª – En la web de LibreOffice recomiendan (para el caso de instalar la aplicación desde los paquetes disponibles en la web) desinstalar cualquier versión anterior para evitar posibles errores durante y posteriores a la instalación. Si optásemos por realizar este tipo de instalación podemos eliminar todo rastro de una versión previa de la siguiente forma,

sudo apt-get purge libreoffice*

sudo apt-get autoremove libreoffice*

 

3ª – Si ya disponemos de una versión LibreOffice instalada, podremos actualizar directamente a la versión disponible desde PPA.

 

Vamos a ver las diferentes opciones de instalación y así podremos elegir la que más nos convenga o convenza. 

 

INSTALACIÓN DE LibreOffice 3.5 en Ubuntu

    OPCIÓN A) – INSTALACIÓN DESDE PPA OFICIAL

    OPCIÓN B) – INSTALACIÓN DESDE LOS PAQUETES .DEB

________________________________________________________________________________

 

OPCIÓN A) – INSTALACIÓN DESDE PPA OFICIAL

Existe una PPA oficial, pero por lo que se indica (de momento) permite instalar libreoffice en modo “testing” ya que no han sido probados todos los paquetes con garantias plenas, y el objetivo es que los usuarios los sometan a todo tipo de pruebas antes de ser publicados; se indica que la versión estable para cada versión estará disponible en los repositorios de la misma.

« Most of the packages in this ppa have only experienced minor testing — in fact it is the place to enable a wider audience to test packages before they are published into the distro proper. In general this ppa is _not_ for the average user to install without a closer look (if it would be, its packages would be in the main repositories).

In general, users are adviced to take a look at the changelog for the details about a package. If there is a specific bug that is intended to be addressed by an update released into the ppa, you are encouraged to test, if the update solves that problem. Packages published after the distro release are mostly such specific fixes. Critical fixes will SRUed into the main repositories after testing anyway (later, with more testing) »

 

A.1  – Si ya disponemos de una versión instalada, la actualizamos de la siguiente forma

sudo add-apt-repository ppa:libreoffice/ppa

sudo apt-get update

sudo apt-get upgrade

 

A.2  – Si no tenemos instalada ninguna versión previa, la instalamos de la siguiente forma

sudo add-apt-repository  ppa:libreoffice/ppa

sudo apt-get update

sudo apt-get install  libreoffice

 

♦ Por defecto la instalación lo deja en inglés. Para ponerlo en español tecleamos

sudo apt-get install  libreoffice-l10-es

 

♦ Si en este momento abrimos el entorno LibreOffice vemos que es un tanto peculiar. Podemos no obstante mejorar la compatibilidad con GNOME instalando el siguiente paquete

sudo apt-get install  libreoffice-gnome

Si trabajamos con KDE el paquete que mejora la compatibilidad con KDE es el siguiente

sudo apt-get install  libreoffice-kde

 

♦ El menú de la aplicación no se integra por defecto en el menú de escritorio de Ubuntu, pero podemos hacer que lo haga si así lo deseamos

sudo apt-get install  lo-menubar

sudo apt-get update

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Si queremos dejarlo tal cual viene por defecto basta con teclear

sudo apt-get remove  lo-menubar

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

 

 

OPCIÓN B) INSTALACIÓN DESDE LOS PAQUETES .DEB

De esta forma podremos disponer de la última versión liberada en la web de The Document Foundation.

1.- DESCARGAMOS LOS PAQUETES

2.- INSTALAMOS LA SUITE

3.- INSTALAMOS EL PAQUETE CORRESPONDIENTE A NUESTRO IDIOMA

4.- INSTALAMOS EL PAQUETE DE AYUDA


1.- DESCARGAMOS LOS PAQUETES

Ver la 2ª – Consideración Previa

Nos bajamos los paquetes correspondientes a nuestro sistema 32 bits o 64 bits  (paquete de la suite + paquete de idioma + paquete de ayuda) desde la página de descarga  https://es.libreoffice.org/descarga/

Vamos a ver el proceso de instalación para sistemas de 32 bits (se haría igual para sistemas de 64 bits utilizando por supuesto los paquetes correspondientes).

En el momento de la redacción de este artículo los paquetes correspondientes a la última versión liberada son los siguientes:

LibO_3.5.1_Linux_x86_install-deb_en-US.tar.gz

LibO_3.5.1_Linux_x86_langpack-deb_es.tar.gz

LibO_3.5.1_Linux_x86_helppack-deb_es.tar.gz

 

2.- INSTALAMOS LA SUITE

Una vez descargado descomprimimos el archivo en la carpeta  /opt (en principio es la carpeta destinada a las aplicaciones que instalamos los usuarios). Para ello nos vamos a una terminal, nos situamos en la carpeta en la que hemos descargado los paquetes y tecleamos

sudo tar xzvf  LibO_3.5.1_Linux_x86_install-deb_en-US.tar.gz -C /opt

se genera la carpeta  /LibO_3.5.1rc2_Linux_x86_install-deb_en-US/DEBS  conteniendo los archivos “.deb“. Los instalamos,

sudo dpkg -i  /opt/LibO_3.5.1rc2_Linux_x86_install-deb_en-US/DEBS/*.deb

a continuación instalamos el paquete de integración con el escritorio que se encuentra en la carpeta  /LibO_3.5.1rc2_Linux_x86_install-deb_en-US/DEBS/desktop-integration

sudo dpkg -i  /opt/LibO_3.5.1rc2_Linux_x86_install-deb_en-US/DEBS/desktop-integration/*.deb

 

3.- INSTALAMOS EL PAQUETE CORRESPONDIENTE A NUESTRO IDIOMA

Nos situamos en la carpeta donde lo hemos descargado y tecleamos,

sudo tar xzvf  LibO_3.5.1_Linux_x86_langpack-deb_es.tar.gz   -C /opt

se genera la carpeta  /LibO_3.5.1rc2_Linux_x86_langpack-deb_es/DEBS  conteniendo los archivos “.deb“. Los instalamos,

sudo dpkg -i  /opt/LibO_3.5.1rc2_Linux_x86_langpack-deb_es/DEBS/*.deb

 

 4.- INSTALAMOS EL PAQUETE DE AYUDA

Nos situamos en la carpeta donde lo hemos descargado y tecleamos,

sudo tar xzvf  LibO_3.5.1_Linux_x86_helppack-deb_es.tar.gz -C /opt

se genera la carpeta  /LibO_3.5.1rc2_Linux_x86_helppack-deb_es/DEBS  conteniendo el archivo “.deb“. Lo instalamos,

sudo dpkg -i  /opt/LibO_3.5.1rc2_Linux_x86_helppack-deb_es/DEBS/*.deb

 

♦ Finalmente borramos las carpetas con los archivos de instalación; lo haremos desde la terminal con el comando rm ya que  /opt  es una carpeta con permisos especiales y necesitamos permiso de superusuario. Podemos borrar una a una, o las tres carpetas a la vez utilizando un comodín de la siguiente forma

sudo rm -r  /opt/LibO_3.5.1*

Si no queremos conservar los archivos que descargamos de la web también podemos borrarlos. En este caso basta con seleccionarlos con el ratón y eliminarlos.

 

¡ IMPORTANTE !

La integración del menú de la aplicación en el menú de escritorio, en este caso no es posible. Si intentamos instalar el paquete lo-menubar el sistema detecta la versión existente en PPA y procedería a instalarla omitiendo la que tenemos, esto ocasiona diversos problemas como por ejemplo en el idioma de la interfaz de la aplicación. En el momento en que la versión que instalamos corresponda con la existente en PPA estos problemas no surgirán.

 

Una vez finalizada la instalación accedemos a todos los componentes de LibreOffice 3.5 desde  Inicio -> Aplicaciones

Fuentes -> LibreOffice, wikidocumentfoundation

Publicado el 17 marzo, 2012 en Aplicaciones, Linux, Ubuntu y etiquetado en , , , , . Guarda el enlace permanente. 5 comentarios.

  1. Luis Fabricio Escalier

    Muchas gracias-… me sirvió de mucho tu post… por que?? porque en el archivo README del primer paquete no dice en ningún momento que instalemos el paquete de Integración con el escritorio … así que imaginate, ya estaba por des-instalar todo…XD …
    Ah!!! no hay ningún problema si no instalo el paquete de ayuda no??

  2. Muchas, muchas gracias amigo me sirvió super este pequeño tutorial… se te agradece!!

  3. Hola, he seguido los pasos que recomiendas y he tenido problemas para instalarlo ya que después de haber desisntalado el openoffice y comenzar el proceso que denominaste A2, introduje la línea de comando « sudo apt-get update » me aparece en el terminal lo siguiente:

    Leyendo lista de paquetes… Hecho
    W: Error de GPG: http://deb.opera.com stable Release: Las firmas siguientes no se pudieron verificar porque su llave pública no está disponible: NO_PUBKEY AAFF4A5B336064B5

    Parece ser que no me es posible continuar el proceso de instalación, ¿sabrías cómo pudiera hacerle para continuar el proceso para instalar Libreoffice?

    Gracias y Saludos

    • Hola Alberto. Parece ser que en algún momento trataste de instalar el navegador web Opera y no terminaste dicha instalación al no disponer de su llave pública. Por este motivo, cada vez que intentes actualizar repositorios va a lanzarte el error que mencionas, pero no tiene nada que ver con la instalación de LibreOffice. No obstante el error tiene solución; sigue los pasos que indico en el artículo
      Cómo Solucionar el Error NO_PUBKEY en Ubuntu

      En cualquier caso puedes seguir con la instalación de LibreOffice.
      NOTA.- La PPA oficial de LibreOffice dispone de paquetes de instalación a partir de Ubuntu 10.04 LTS (Lucid Lynx). Allí se indica que dispone de los paquetes de instalación de LibreOffice 3.5 (es posible que no hayan actualizado el texto); te digo esto porque ya se ha publicado la versión 3.6, la cual se encuentra disponible en los repositorios de Ubuntu 12.10 Quantal Quetzal. Si fuese este el caso y quisieses instalar la última versión de LibreOffice, puedes hacerlo siguiendo la OPCIÓN B) INSTALACIÓN DESDE LOS PAQUETES .DEB

      Un saludo.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s