Archivos Mensuales: octubre 2010

Resolver dependencias para un paquete ".deb"

En ocasiones ocurre que, intentando instalar un programa desde su paquete “.deb” bajado de la red, Ubuntu me dice que no puede instalarlo porque no puede resolver las dependencias del mismo. Cuando esto ocurre lo soluciono de la siguiente manera:
Instalo el paquete “.deb” con

sudo dpkg -i nombredelpaquete.deb

Luego resuelvo las dependencias haciendo

sudo apt-get install -f

Activar Control+Alt+Backspace para reiniciar servidor X en Ubuntu

A igual que en Ubuntu 10.04 la opción Control+Alt+tecla retroceso, que reinicia el entorno gráfico, se encuentra desactivada. Puede no obstante activarse yendo a Sistema/Preferencias/Teclado; luego Pestaña Distribuciones, y en Opciones de Distribución habilitamos la opción Secuencia de Teclas para matar el servidor X.

 

Añadir REPOSITORIOS PPA a Ubuntu 10.10

En ocasiones nos ocurrirá que queremos instalar una determinada aplicación y Ubuntu nos muestra un error de que “no encuentra el paquete”, esto se debe probablemente a que estamos intentando instalar una aplicación y no tenemos un repositorio que nos permita acceder a ella. La solución consiste en “añadir el repositorio correspondiente” y actualizar la lista de repositorios para que Ubuntu sepa asociar aplicaciones y repositorios.

Podemos gestionar repositorios de varias formas: con Synaptic, Ubuntu-tweak, Ailurus, de manera manual, o editando como usuario “root” el fichero /etc/apt/sources.list y añadiendo las lineas del repositorio correspondiente.

Desde Ubuntu 9.10 (Karmic Koala) se incluyó el comando “add-apt-repository” que facilita la tarea de añadir repositorios desde la consola, cuya sintaxis es la siguiente:

sudo add-apt-repository [repositorio PPA que se quiere añadir]

 

De esta forma Ubuntu se encarga de añadir ese repositorio a nuestro fichero /etc/apt/sources.list y de importar la clave del mismo.

He instalado Ubuntu 10.10 (Maverick Meerkat)…

   He podido comprobar que todo lo que he recogido en el artículo  Ubuntu 10.04 Lucid Lynx y ahora qué?…, es válido para Ubuntu 10.10 (Maverick Meerkat).